xaizek / hstr (License: Apachev2) (since 2018-12-07)
Bash and Zsh shell history suggest box - easily view, navigate, search and manage your command history.
<root> / PKGBUILD (926b8820132b232f4141894a0c48badef4eea5d2) (671B) (mode 100644) [raw]
# Maintainer: Ricardo Band <me@xengi.de>
pkgname=hh
pkgver=1.2.1
pkgrel=1
pkgdesc="A command line utility that brings improved BASH command completion from the history. It aims to make completion easier and more efficient than Ctrl-r."
arch=('any')
url="https://github.com/dvorka/hstr"
license=('Apache')
makedepends=('readline' 'ncurses')
_pkgver=$(echo "$pkgver" | sed 's/.[0-9]*$//')
source=(https://github.com/dvorka/hstr/releases/download/$pkgver/$pkgname-$_pkgver-src.tgz)
md5sums=('a6b7ab128fff5604374166b488c7b8b7')

build() {
    cd "$srcdir/hstr"
    ./configure --prefix=/usr
    make
}

package() {
    cd "$srcdir/hstr"
    make DESTDIR="$pkgdir/" install
}
Hints

Before first commit, do not forget to setup your git environment:
git config --global user.name "your_name_here"
git config --global user.email "your@email_here"

Clone this repository using HTTP(S):
git clone https://code.reversed.top/user/xaizek/hstr

Clone this repository using ssh (do not forget to upload a key first):
git clone ssh://rocketgit@code.reversed.top/user/xaizek/hstr

You are allowed to anonymously push to this repository.
This means that your pushed commits will automatically be transformed into a pull request:
... clone the repository ...
... make some changes and some commits ...
git push origin master